Can I use Vista?

I recently upgraded my computer and I now have Windows Vista Ultimate. I am not sure if the Vista portion of the question is relevant? However my EZ Update service does not work anymore. Everything else works fine. When trying the EZ update service I get a notice thats says ATP Navigator EZ Update Service has encountered an error. Any suggestions ? Regards, M. Ledford

Frequently Asked Questions: 

Mike Your comment about Windows Vista is right on target. NavigatorV(R) uses a Microsoft developed communication protocol (WSE) for EZ Update that is supported on Windows XP and early Vista test kits. However, Microsoft made a number of late changes to Vista including updating the communication protocol in the initial release version. For this reason, EZ Update did not work on the initial Visa release however Microsoft released a Vista upgrade that fixes compatability issues with the communication protocol in Vista. ATP NavigatorV is fully funtional with WSE 2.0 SP3 installed on Vista.